Windows 8 1.156 Themen, 15.574 Beiträge

Win8.1 - Icon-Cache wird ständig gelöscht

Oliver1967 / 8 Antworten / Baumansicht Nickles

Moin, Jungs!

Ich hab Windows 8.1 (x64, mit allen Updates) mittlerweile an meine Bedürfnisse soweit angepasst, daß ich schon bereit bin, es als Ersatz für Windows 7 zu akzeptieren.

Ich habe mit Fremd-Software das Start-Menü, die Desktop-Gadgets und das Aero-Glass-Design soweit wieder hergestellt, daß es zusammen mit dem neuen Windows-Explorer und der verbesserten Grafik-Maschine durchaus eine Verbesserung gegenüber Win7 darstellt.

Was mir aber echt den Spaß verdirbt, ist die Tatsache, daß dieses Win 8.1 etwa einmal täglich sämtliche Icon-Symbole "vergißt" und mir erstmal wieder nur leere gelbe Ordner-Symbole anzeigt. Ich repariere dann mit "Tweaking.com - Windows Repair Portable" den Icon-Cache, so daß nach einem System-Neustart die Datei-Symbole wieder neu gespeichert werden.

Ich weiß leider nicht, welche Veränderungen dieses Programm in der Registry vornimmt, sonst würde ich diese Werte gegen neuerliche Veränderungen sperren.

Um es nochmal klarzustellen: Es geht nicht um die Ordneransicht nach dem Muster Liste/Details/Kacheln/große Symbole/etc., sondern um die Ansicht der Datei-/Ordnersymbole als grafische Symbole.

Hat jemand eine Idee, welcher Registry-Wert dafür zuständig ist oder wie ich dieses Problem sonstwie beseitigen kann?

bei Antwort benachrichtigen
Tom West Oliver1967

„Win8.1 - Icon-Cache wird ständig gelöscht“

Optionen

Evtl. hilft es, den Icon-Cache zu erhöhen

Registry: HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Explorer

Neue Zeichenfolge anlegen: "Max Cached Icons" (ohne Anführungszeichen) und Wert von z.B. 5000 zuweisen (der normale Cache beträgt 500)

bei Antwort benachrichtigen
Oliver1967 Tom West

„Evtl. hilft es, den Icon-Cache zu erhöhen Registry: ...“

Optionen

Der Wert stand auf 4000, hab ihn mal auf 5000 erhöht. Ich bin jetzt nicht sicher, wo das Maximum ist. Bis Win7 waren es 7000, glaube ich. Aber wenn man das Maximum überschreitet, wird der Wert ignoriert und Windows verwendet das Minimum, wenn ich mich recht erinnere.

Daran hab ich also auch schon gedacht, aber das ist nicht die Ursache des Problems.

Es passiert immer beim Navigieren im Explorer. Ich öffne irgendeinen Ordner, dann "stolpert" der Explorer ganz kurz, und alle Symbole sind weg.

Und Win8 hat ja sowieso von Anfang an die blöde Angewohnheit gehabt, die Ordnerinhalte sehr langsam einzulesen. Deutlich langsamer als XP oder Win7.

Das ist echt traurig, daß ein so läppisches Problem einem die Arbeit mit dem ganzen Betriebssystem versaut...

Und Microsoft selbst hat auf seinen Seiten auch nichts zu diesem Thema anzubieten.

bei Antwort benachrichtigen
Tom West Oliver1967

„Der Wert stand auf 4000, hab ihn mal auf 5000 erhöht. Ich ...“

Optionen

Oliver,

nichts für ungut. Der Wert existiert normalerweise nicht. Insoweit ist also wohl Einiges "getweakt" worden. Warum Du das dann auf W8(1) schiebst, eröffnet sich mir jetzt nicht. Das Problem mit den Icons hat bei mir auch unter W7 existiert.

Ich benutze W8.1 völlig ohne Zusatz.

Noch ein kurzer Hinweis auf Dein Post (nicht bös verstehen):

Ich weiß leider nicht, welche Veränderungen dieses Programm in der Registry vornimmt, sonst würde ich diese Werte gegen neuerliche Veränderungen sperren.
Hat jemand eine Idee, welcher Registry-Wert dafür zuständig ist oder wie ich dieses Problem sonstwie beseitigen kann?

Der Icon-Cache ist es und Du weißt es ;)

bei Antwort benachrichtigen
Oliver1967 Tom West

„Oliver, nichts für ungut. Der Wert existiert normalerweise ...“

Optionen

Das kann gut sein, daß ich den Wert selber eingefügt habe. Wenn ich ein neues Windows einrichte, nehme ich standardmäßig so sechs oder sieben Einstellungen in der Registry vor. Da ich das aber schon länger nicht mehr gemacht habe, wusste ich gar nicht mehr, daß ich den Wert selber erstellt habe.

Aber dieser Wert ist ja nun mal nicht das Problem! Der Cache wird gelöscht, lange bevor er voll ist.

Das hatte ich weder bei XP noch bei Windows 7. Deshalb "schiebe" ich es auf Windows 8.

Ich suche nach dem Auslöser für das Löschen.

bei Antwort benachrichtigen
shrek3 Oliver1967

„Das kann gut sein, daß ich den Wert selber eingefügt ...“

Optionen

Ich erinnere mich noch an einen Thread mit jueki, der üblicherweise Win 8 mit Classic Shell ausstattet. Es ging in diesem Thread darum, dass er eine bestimmte Funktion nicht wahrnehmen konnte.

Ich wies ihn darauf hin, dass dies etwas damit zu tun haben könnte, seine Rechner (nicht nur Win 8-Rechner) nach seinem eigenwilligen Vorstellungen umzufunktionieren.

Wie es halt typisch für jueki ist, installierte er daraufhin Win8 nochmals neu - dieses Mal aber ohne Classic Shell.

Und siehe da, das, was ihm vorher versagt blieb, lief nun einwandfrei.

Gruß
Shrek3

Fatal ist mir um das Lumpenpack, das, um Herzen zu rühren, den Patriotismus trägt zur Schau, mit all seinen Geschwüren. Heinrich Heine
bei Antwort benachrichtigen
Oliver1967 shrek3

„Ich erinnere mich noch an einen Thread mit jueki, der ...“

Optionen

Interessant! Ich habe nämlich tatsächlich Classic Shell installiert, um das Startmenü wieder herzustellen.

Ich glaube, ich werde morgen mal Win8 neu aufsetzen und probeweise auf dieses Programm verzichten.

Allerdings graust es mich schon vor den 43 Millionen Updates, die ich dann neu einspielen muß...

Ich werd Euch morgen mal bescheid geben, was draus geworden ist.

bei Antwort benachrichtigen
Olaf19 Oliver1967

„Interessant! Ich habe nämlich tatsächlich Classic Shell ...“

Optionen

Könntest du stattdessen nicht einfach die Classic Shell de-installieren?

Wenn das nicht hilft, kannst du ja hinterher immer noch das System neu aufsetzen. Nicht dass du dir jetzt diese horrende Arbeit machst und es wäre vielleicht gar nicht nötig gewesen.

CU
Olaf

"Das sind Leute, die von Tuten und Ahnung keine Blasen haben" (ein Reporter auf die Frage nach der politischen Bildung des typischen Anhangs von Donald Trump)
bei Antwort benachrichtigen
Oliver1967 Olaf19

„Könntest du stattdessen nicht einfach die Classic Shell ...“

Optionen

Ja, da bin ich dann auch drauf gekommen, einen Augenblick, nachdem ich den Beitrag geschrieben hatte.

bei Antwort benachrichtigen