Linux 14.981 Themen, 106.343 Beiträge

Numlock startet nicht automatisch

unhold06 / 8 Antworten / Baumansicht Nickles

Hallo Gemeinde,

ich wende mich an die Linux-Kenner hier im Forum mit einem Problem, welches mich seit einiger Zeit plagt.

Numlock startet nicht wie gewohnt mehr automatisch, was in der Vergangen immer funktionierte.

Die Einträge in etc/default/numlocks sind:

# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=auto

Im "Startpromme" ist ebenfalls ein Eintrag vorhanden.

Ebenfalls ist im BIOS Numlock auf on.

Das Problem tritt nur unter Ubuntu auf. Win 10 ist davon nicht bertoffen.

Das Linux ist Ubuntu 20.04 /64 Bit

Danke für Eure Hilfe.

Gruß

unhold06

Die Welt k?nnte so sch?n sein. G?be es nicht Hass, Neid und die unendliche Dummheit der Menschen.
bei Antwort benachrichtigen
lexlegis unhold06 „Numlock startet nicht automatisch“
Optionen

Hallo, was passiert denn, wenn du den Wert "auto" auf "on" änderst?

Ich kenn mich leider kaum mit Linux aus, und weiß auch gar nicht, ob die Datei auch abgearbeitet wird beim Start :)

Gruß lexlegis

Work it harder, make it better, do it faster, makes us stronger
bei Antwort benachrichtigen
unhold06 lexlegis „Hallo, was passiert denn, wenn du den Wert auto auf on änderst? Ich kenn mich leider kaum mit Linux aus, und weiß auch ...“
Optionen

Hallo lexlegis,

Danke für Dein Interesse, leider ist Deine Idee für mich wenig hilfreich. Stirnrunzelnd

Gruß

unhold06

Die Welt k?nnte so sch?n sein. G?be es nicht Hass, Neid und die unendliche Dummheit der Menschen.
bei Antwort benachrichtigen
violetta7388 unhold06 „Numlock startet nicht automatisch“
Optionen

Hallo unhold06,

als erstes im Bios nachschauen was dort zum Nummernblock gesetzt ist.

Anschließend unter Systemeinstellungen >> Hardware >>Tastatur usw. den automatischen Start des Nummernblocks aktivieren.

Habe im Moment kein Ubuntu aktiv auf dem Rechner, sonst hätte ich Dir den Weg genau beschrieben. Ist aber i.d.R. nur eine Kleinigkeit.

MfG.

violetta

PS.: und noch ein Link: https://wiki.ubuntuusers.de/Nummernblock_aktivieren/

bei Antwort benachrichtigen
unhold06 violetta7388 „Hallo unhold06, als erstes im Bios nachschauen was dort zum Nummernblock gesetzt ist. Anschließend unter ...“
Optionen

Moin violetta,

ganz vielen Dank für Deinen Tipp.

Numlock im BIOS aktiv,

automatischer Start Nummernblock aktiv.

Bin am Ende meines Latein. Die Wege auf Ubuntuusers.de habe ich alle abgearbeitet, ohne Erfolg.

Als Entkonsequenz bleibt mir nur das Händische aktivieren.Stirnrunzelnd

Dennoch Danke für die Mühe.

Schönes WE

Gruß

unhold06

Die Welt k?nnte so sch?n sein. G?be es nicht Hass, Neid und die unendliche Dummheit der Menschen.
bei Antwort benachrichtigen
violetta7388 unhold06 „Moin violetta, ganz vielen Dank für Deinen Tipp. Numlock im BIOS aktiv, automatischer Start Nummernblock aktiv. Bin am ...“
Optionen

Hallo unhold06,

Du hast die Option "Auto" gewählt. Probiere die Option "on" als letzten Versuch. Ansonsten heißt es auf das nächste update zu warten.

MfG. und ein sonniges, erholsames Wochenende

violetta

bei Antwort benachrichtigen
fakiauso unhold06 „Numlock startet nicht automatisch“
Optionen

Und wenn Du die Datei numlocks einfach einmal auskommentierst, damit sie überhaupt nicht ausgewertet wird, sondern die BIOS-Settings übernommen werden?

Nächster Ansatz wäre Klickibunti unter Einstellungen-->Tastatur und dort den Ziffernblock einschalten?

https://wiki.ubuntuusers.de/Nummernblock_aktivieren/#Unity-GNOME

Keine Ahnung wie das bei einem aktuellen 20.04 aussieht, aber das wird ja dann Gnome als Oberfläche haben.

Das Paket numlockx selber ist installiert?

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
unhold06 fakiauso „Und wenn Du die Datei numlocks einfach einmal auskommentierst, damit sie überhaupt nicht ausgewertet wird, sondern die ...“
Optionen

Habe den Fehler gefunden. Schuld war ein Tippfehler im Autostart. Statt numlockx, habe ich numlocks eingetippt. Stirnrunzelnd

Vielen Dank für Eure Beiträge.

Gruß

unhold06

Die Welt k?nnte so sch?n sein. G?be es nicht Hass, Neid und die unendliche Dummheit der Menschen.
bei Antwort benachrichtigen
fakiauso unhold06 „Habe den Fehler gefunden. Schuld war ein Tippfehler im Autostart. Statt numlockx, habe ich numlocks eingetippt. Vielen Dank ...“
Optionen
Statt numlockx, habe ich numlocks eingetippt.


Hihi and thanks for the feedback;-)

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen