Linux 14.929 Themen, 105.580 Beiträge

Open Suse Linux startet nur noch in den emergency mode

Stevie7 / 8 Antworten / Baumansicht Nickles

Hallo zusammen,

mein Open Suse (Tumbleweed) startet nur noch in den emergengy modus. Zuletzt hatte ich über den Partitionierer eine neue Festplatte partitioniert. Anschließend ist die Fehlermeldung "efi-bootloader" nicht gefunden aufgetreten. Ich hatte dann über die Konsole yast gestartet und den bootloader neu in Grub2 getauscht. Jedefalls kommt die Fehlermeldung jetzt nicht mehr. Aber der Rechner bootet trotzdem nur in den emergency mode.

Zwei der Fehlermeldungen, die journalctl -xb

ausgibt sind:

systemd-vvconsole-setup[273]: /usr/bin/loadkeys failed with exit status 1

systemd[1]: Failed to start Virtual Console

Bootversuche aus dem emergency modus (init 5, systemctl default oder ctrl+D) waren leider nicht erfolgreich.

Für sachdienliche Hinweise zur Lösung des Problems wäre ich sehr dankbar!

Vielen Dank & beste Grüße,

Stevie

System:

Open Suse Tumbleweed x64

Kernel 4.16.3-1

KDE

bei Antwort benachrichtigen
violetta7388 Stevie7

„Open Suse Linux startet nur noch in den emergency mode“

Optionen

Hallo Stevie7,

beschreibe Dein System einmal genauer. Welche BS laufen? Was läuft in der virtuellen Konsole?

Alternativ kannst Du über Deine Installations-CD  einfach ein up date fahren (keine Wiederherstellung!), dann werden der richtige Bootloader und die Bootpfade automatisch gewählt.

MfG.

violetta

bei Antwort benachrichtigen
Stevie7 violetta7388

„Hallo Stevie7, beschreibe Dein System einmal genauer. Welche BS laufen? Was läuft in der virtuellen Konsole? Alternativ ...“

Optionen

Hallo Violetta,

das Hauptsystem ist Tumbleweed. Daneben ist ein altes Windows XP, ein Zorin Linux (Ubuntu) und ein Deepin Linux installiert auf einer SSD. Das Suse Linux liegt auf einer Festplatte.

Eine virtuelle Konsole läuft eigentlich gar nicht. Daher wundert mich die Meldung auch. Die Wiederherstellung über eine aktuelle Installations-"CD" habe ich schon mehrmals probiert, leider ohne Erfolg. Da gibt es eine Yast Fehlermeldung.

Hast du vielleicht eine Idee, wie ich das Suse wieder zum Laufen bekomme?

Lieben Dank!

Viele Gruesse, Stevie

bei Antwort benachrichtigen
violetta7388 Stevie7

„Hallo Violetta, das Hauptsystem ist Tumbleweed. Daneben ist ein altes Windows XP, ein Zorin Linux Ubuntu und ein Deepin ...“

Optionen

Hallo Stevie,

habe ich teilweise schon empfohlen.

Entweder den Bootloader händisch mit Hilfe von Yast aktualisieren oder ein schnelles up date oder eine kurze Neuinstallation. Du mußt sehen, was am einfachsten möglich ist und Erfolg verspricht.

MfG.

violetta

bei Antwort benachrichtigen
Stevie7 violetta7388

„Hallo Stevie, habe ich teilweise schon empfohlen. Entweder den Bootloader händisch mit Hilfe von Yast aktualisieren oder ...“

Optionen

Hallo Violetta,

vielen Dank für Deine Antwort!

Ich habe jetzt nochmal ein update probiert mit einer alten CD. Das hat funktioniert - aber starten tut es leider immer noch nicht. Eine Yast Bootloader Aktualisierung hat auch funktioniert - ich hab nach dem update wieder auf Grub2  umgestellt. Trotzdem gleiche Fehlermeldung.

Hilft da wirklich nur eine Neuinstallation?

Viele Grüße,

Stevie

bei Antwort benachrichtigen
violetta7388 Stevie7

„Hallo Violetta, vielen Dank für Deine Antwort! Ich habe jetzt nochmal ein update probiert mit einer alten CD. Das hat ...“

Optionen

Hallo Stevie7,

was startet nicht? 

Hast Du im Bootloader explizit Opensuse als erste Startpartition gemarkert und ist der Bootloader bereinigt? Glaube fast, dass die Fehlermeldung nicht von Opensuse kommt und ein alter Rest vorhanden ist.

Eine Neuinstallation ist immer das allerletzte Mittel.

MfG.

violetta

bei Antwort benachrichtigen
Stevie7 violetta7388

„Hallo Stevie7, was startet nicht? Hast Du im Bootloader explizit Opensuse als erste Startpartition gemarkert und ist der ...“

Optionen

Das ge-up-datete Suse startet nicht.

Ich habe den Bootloader über Yast neu geschrieben. Die Einstellungen sind: 

Grub2

aus Master Boot Record starten

Aktiv-Fag in Partitionstabelle für Bootpartition setzen

Generischen Bootcode in MBR schreiben

Wie genau kann ich den Bootloader bereinigen?

bei Antwort benachrichtigen
fakiauso Stevie7

„Das ge-up-datete Suse startet nicht. Ich habe den Bootloader über Yast neu geschrieben. Die Einstellungen sind: Grub2 aus ...“

Optionen

Wenn es über die Bordmittel nicht funktioniert, dann wäre Super Grub Disk noch eine Option.

Laden und lesen kannst Du hier.

Wahrscheinlich hast Du beim Partitionieren etwas verhauen oder den falschen MBR mit dem Bootloader beglückt. Ich würde bei einem Multibootsystem vorerst nur die Suse-Platte drin lassen und diese versuchen, wieder bootfähig zu bekommen.

Auf alle Fälle ist Start aus dem MBR und das Active-Flag im Grunde korrekt.

Die Fehlermeldungen aus dem Startpost deute ja darauf hin, dass die Tastaturbelegung nicht geladen werden kann und daher auch systemd nicht in der Lage ist, die virtuelle(n) Konsole(n) zu starten. Deutet eigentlich auch auf einen verbogenen Plattenpfad hin.

Falls Du mit o.g. Disk erst einmal Tumbleweed gestartet bekommst, kannst Du es auch mit einem

sudo update-grub
sudo grub-install /dev/sdx

versuchen. Statt des x natürlich dann den Buchstaben der Festplatte angeben, bei einer einzigen sicher dann /dev/sda.

"Anyone who believes exponential growth can go on forever in a finite world is either a madman or an idiot (or an economist)" - Hellsongs
bei Antwort benachrichtigen
Stevie7 fakiauso

„Wenn es über die Bordmittel nicht funktioniert, dann wäre Super Grub Disk noch eine Option. Laden und lesen kannst Du ...“

Optionen

vielen Dank für Deine Antwort!

Also ich habe alles probiert, was du vorgeschlagen hast. Zusätzlich habe ich noch probiert den Bootloader zu modifizieren und die Parameter anzupassen. Leider ohne Erfolg. Bei sudo update-grub kam das ich keine valide EFI-Bootpartition / kein EFI Fallback.

Auch SuperGrub hatte nichts geholfen. Nun habe ich das System neu aufgesetzt und es läuft wieder.

Vielen herzlichen Dank Dir & Violetta für Eure Hilfe!

Beste Grüße,

Stevie

bei Antwort benachrichtigen