Fotografieren und Filmen 2.957 Themen, 18.344 Beiträge

IP Cam, Portfreigabe, welcher Port ?

hexihex / 2 Antworten / Baumansicht Nickles

Hallo,
ich habe ein Problem mit meiner IP Cam. Vor längerer Zeit hatte ich mich auf Manfred's (Angelpage) Seiten durchgelesen, um das Ding zum Laufen zu bringen, was auch klappte. Von außerhalb habe ich nie auf die Cam zugegriffen, aber ich nehme mal an, das hätte auch funktioniert. Mit dem Wechsel des Betriebssystems (zuvor XP SP3 x68), jetzt Win7 x64 stellten sich nach kurzer Zeit Probleme ein, die sich auf den Port beziehen.

meine ursprünglich funktionierende Konfiguration:
- Cam: feste IP (DHCP aus), Port 80 (default) lt. Herstellerhinweis auf anderen Port (8990) geändert.
- Router: freie DynDNS ausgewählt, UpNp deaktiviert
Portfreigabe für IP Cam: andere Anwendung (TCP), von Port 8090 bis Port 8090 an IP der Cam, Port: 8090
- in der Cam keine DynDNS Anbieterangaben, UpNp deaktiviert

Das müsste, soweit ich weiß auch richtig sein. Mit dem Wechsel des Betriebssystems nun war plötzlich eine Portfreigabe für UDP erforderlich, die ich in der obern beschriebenen Weise vorgenommen habe. Anfangs ging das auch, doch jetzt erhalte ich wenn der Bewegungsmelder der Cam auslöst nur noch eMails, die keine Bilder mehr enthalten. Ich habe also nachgeforscht, und da es nicht an meinen Maileinstellungen in der Cam liegt, habe ich mir auch die Portlisten angesehen. Ergebnis: Port 8090 ist offenbar gar nicht für UDP geeignet. Nun weiß ich nicht so recht, welchen Port ich nehmen könnte.

Um andere Probleme ggf. auszuschließen habe ich die Cam heute deinstalliert und anschließend neu installiert. Anschließend habe ich in dem Tool, dass zur ersten Verbindung gestartet wird, auch den Pfad geändert (von System 32 nach SysWOW64), weil die Kamera mit einer 32- bit Software läuft und die IP Cam.exe dann ja im Ordner SysWOW installiert ist. Soweit ist m.E. auch alles o.k.
Irgendwann bei der Arbeit hatte ich dann allerdings mal meine Firewal - Einstellungen überprüft: IP Cam war erlaubt und ich folgte dem Link zum Port um auch das zu prüfen.
Zu meiner Überraschung wurde hier der Port 10000 (ein/aus) für UDP angezeigt und mein zuvor angezeigter TCP Port 8090 war verschwunden. (Die Cam war zu diesem Zeitpunkt über WLAN angebunden. Das war zuvor genauso, aber mit dem Unterschied, dass sie über ein LAN - Kabel mit dem Router verbunden war, damit im Tool die IP der Cam angezeigt wird und per Link zum Browser verbindet.)
Na ja, meine erster Gedanke war also: Portfreischaltung für TCP 8090 und Portfreischaltung für UDP 10000 im Router einzutragen.
Vorsichtshalber habe ich aber noch Portlisten gegoogelt um nachzusehen, ob 10000 nicht auch für TCP geht und jetzt bin ich mir total unsicher. Schon auf der ersten gefundenen Seite wurde angemerkt, dass Port 10000 als ehemaliges Einfalltor für Trojaner bekannt sei.
Weitere Erkundungen ergaben, dass das ggf. auch vom verwendeten Dienst abhängen kann, aber wie meine Cam schließlich arbeitet, weiß ich ja nicht.
Jedenfalls möchte ich Port 10000 wegen eben des Hinweises nicht unbedingt verwenden.
Daher meine Frage: welche Ports könnte ich geschickter Weise verwenden?
Die Bilder der Kamera habe ich bislang lokal, d.h. mit den eMails gespeichert und auch per FTP auf meinen Webspace hochgeladen.
Das möchte ich vorläufig auch so belassen, bis ich mich mit dem Smarthone (bin Handy - Neuling) eingearbeitet habe.

Für Tipps und Ideen wäre ich sehr dankbar.

Gruß, hexihex

bei Antwort benachrichtigen
mi~we hexihex „IP Cam, Portfreigabe, welcher Port ?“
Optionen

Hm...

Von außerhalb habe ich nie auf die Cam zugegriffen

Wozu hast du dann Portweiterleitungen im Router eingerichtet? Wenn dir die Kamera nur Bilder per Mail zuschicken soll, ist das völlig unnötig. Diese Portweiterleitungen brauchst du nur, wenn du vom Internet aus auf die Kamera zugreifen willst.

doch jetzt erhalte ich wenn der Bewegungsmelder der Cam auslöst nur noch eMails, die keine Bilder mehr enthalten.

Das muss dann eine andere Ursache haben....

"Es wäre dumm, sich über die Welt zu ärgern. Sie kümmert sich nicht darum." (Marc Aurel)
bei Antwort benachrichtigen
hexihex mi~we „Hm... Wozu hast du dann Portweiterleitungen im Router ...“
Optionen

Hallo mi~we, ich wollte ja von außerhalb darauf zugreifen, z.B. mit dem PC der Verwandschaft, wenn ich im Urlaub "Haushüter" bin. dafür blieb dann aber letztlich nie Zeit. Was die andere Ursache betrifft, so habe ich gerade festgestellet, dass der IE (nutze IE 8 x68 weil die anderen nicht mit der Cam funktionierten) irgendeinen Fehler haben muss. Der steigt einfach aus. Aber die fehlenden Bilder i8n den Mails würde das ja auch nicht erklären und mein mailprogramm habe ich nicht geändert.

bei Antwort benachrichtigen